ISSUE

When trying to print from Edge, the print box appears and then disappears. No error is shown to the user.


CAUSE

There is a bug in the printing app which will affect printing from other apps as well. The issue is most likely caused by a Windows update.


Windows event log shows:

Faulting application name: PrintDialog.exe, version: 10.0.18362.1, time stamp: 0xb40b5d8f

Faulting module name: Windows.UI.Xaml.dll, version: 10.0.18362.449, time stamp: 0xb90db728

Exception code: 0xc000027b

Fault offset: 0x0000000000712ec0


SOLUTION

Open PowerShell with administrative priviliges.

Run the following command. Add-AppxPackage -register C:\Windows\PrintDialog\appxmanifest.xml -DisableDevelopmentMode